Final Fantasy 8 Freeze at Lunar Base

A place to discuss issues with the FF8 disc 3 freezing at the lanar base cut scene.

FFVIII (FF8) - Lunar Base glitch/bug after a cutscene;

I’m on disc 3 at the lunar base. Rinoa goes nuts and while following her, you come to a hallway that triggers a cutscene of monsters falling from the moon… when the scene is over, Squall just stands there. the environment is still moving, sound is playing… but you’re unable to move. No controller or keyboard input buttons work. I have uploaded my save state to my profile if you would like to take a look at it. Its the room before entering the hallway (he is facing the correct direction)… when you enter that room, someone will shout LOOK! … You’ll see what everyone has been mentioning in previous threads on here as well

1 Like

Hey, rook. Thanks for the save game file. I have it now and will shortly see if I can sort out what’s happening on that damn lunar base!

From what I can tell, the problem exists for most users who have the roms and psx bios installed on their computers as well. At least now I can test with different versions on the game to see if at least one works.

I’ll give it a shot today and hopefully will have some good news for you.

Cheers :beers::video_game:

It’s not looking good, @rook

I tried 4 copies from different regions as well as 3 different psx bios’ as well with no luck. The one thing I didn’t try was a PAL Bios with a PAL game. Current game saves won’t work with PAL games as they are pulled from NTSC games so that’s a bummer.

I might set up a PAL version of FF8 to see if that would work. The only catch is that you’d have to play it again from the beginning. There’s also the risk that it still might not even work once you get to the Lunar base. Might not be in English as well…

I can only reach out to the community at this point. Does anyone have a copy of FF8 that loads past the Lunar Cry/Base cut scene? I’ve read online that there are some changes you can make to your emulator but those tactics won’t help in this case. :crossed_fingers:

Hey @EmuBro

Yeah i got the problem too , but what strikes me the most is that is on the exact same place with my original ps1 copy. Game lagged there many times.

If there is a miraculus fix please save us all cause i had the best stats ever . I put the hours :slight_smile:
Cheers and thanks for the amazing site.

2 Likes

I know what you mean. The fact that this is looking like a bug in the game code (and nothing to do with the emulation taking place) has got me pretty jammed up in terms of any kind of fix.

Theories of how to resolve it online have included:

  • Ejecting the game from the disc tray (not an option)
  • Changing some settings in the backend of RetroArch (currently not an option)
  • Smashing the buttons a bunch of random times (0% credibility)

Nothing yet in terms of a combination of region/version or particular bios that would do the trick.

My best bet is likely to set up a PAL version and see if anyone reports getting stuck at the same spot. Probably a good chance they will but who knows.

I remember beating it back in 2002 or so. I’d be willing to give it another go around since I’m pretty couped up at the moment.

Stay safe everyone!
:canada::beers::video_game:

1 Like

The game is remarkably easy to speed run. Particularly due to everything being leveled to your characters. Get a decent magic spell to junction Squalls attack and you can just walk over every boss.

So should I stop playing now? I just started disk 2 and have been enjoying it…

This this ever get solved. I’m so upset about it. I have a save file prior to the FMV if that would help. Does anyone have a save file from immediately after if the “mash buttons” fix worked for you?

1 Like

It did not. Perhaps I might interest you in some other great PSX titles? Some multi-disc games may encounter similar problems as well so just a heads up on that.

I’m upset about something as well if you’re interested in hearing about my problems. I ordered a Samsung HW-Q90R Soundbar and was super pumped to get it. A week later, they shipped me a fucking ultra-wide asus gaming monitor.

That made me upset…