Performance Issues

awesome. thank you. i will def let you know XD

1 Like

All i can think of is whatever pokemon games you can. A few reasons why these are what i suggest. 1) im a huge pokemon fan. 2) the ds games are like they are in slow motion for me. its not bad and i think its on my side of things. 3) i only have one hand so turn based games where i can take my time are best. thank you for everything so far. best emulator site i have ever used.

1 Like

Thanks for the kind words @wsmarshall89! We really appreciate the feedback.

I honestly don’t think it’s your computer. Some DS games are hit or miss when it comes to a smooth experience. Yoshi’s Island for example lags pretty bad for me.

Pretty sure I’m fresh out of Pokemon games for the DS but I’ll keep adding other ones I think might be fun. Swing by from time-to-time to see if there’s anything new.

Thanks again for stopping by! :beers::video_game:

of course. appreciate the work you guys are doing so people can play old school games or games on platforms they dont have.

1 Like

Hi guys, I replied on Twitter but not sure if you got my message. I’m stuck on the disc change screen for disc 3 on Final Fantasy 7. You worked miracles helping me get from disc 1 to disc 2. Hoping you can do the same again! I have the save state uploaded to my profile, but not sure how to post it here in case you need it. Happy to test it for you if not. Thanks and all the best.

1 Like

Hey @dlicence88

Sorry about not getting back to you on twitter. This is definitely a better place to get our attention so thanks for that.

If you could upload your save state to your user profile page I’ll definitely give it a try. Hopefully I can figure out what the hell is going on with all of these bloody FF related disc problems :confused::man_shrugging:

Cheers :beers::video_game:

Thanks for the reply! I did upload the save state when I created the account, but I can’t seem to find an option to add it anywhere now?! :man_shrugging:

Appreciate the help and the work that’s gone into the website. It’s been great fun going through all the games I played when I was a kid!

1 Like

2 posts were merged into an existing topic: Final Fantasy 8 Freeze at Lunar Base

A place to discuss issues with the FF8 disc 3 freezing at the lanar base cut scene.

1 Like

So, I play on this site during work (when we have downtime- which is a lot lately).

After my FF8 issue, I quickly moved on to FF9. I made it to disc 2 without any issues… However, upon entering Cleyra (after getting slapped around by Beatrice in Burmecia) - I think there is a cutscene when you enter the area. The part enters and starts talking, then they all run into the next area… Freeze- The sound continues to play (the screen is dark, so I can’t give any other description), but it never loads. I had searched it online and found some… odd results.

I forgot to send the save from my home desktop to my account. The results online kept showing that either the physical disc was damaged (it had a chip in it)… others stated that “save states” were to blame. A listed fix was to save in game and then it would work, but I tried and had no luck. I’ll look to find the exact link.

EDIT: KingofCosmos posts an interesting fix. The issue is the same that I was experiencing.

EDIT 2: freeze issue link

  • this one is a bit different, but similar in location and freezing =/

@EmuBro

I loaded some save files for FF9 before the freeze occured into our shared save games. In the save file repository, when you’re adding new titles. Under “game image” - there is no option for ff9 disc 2. I chose disc 1 or 3… but all of my saves are for disc 2 so far

@trix12345 Do you have any FF9 saves AFTER you enter Cleyra on disc 2? I haven’t even started climbing the tree, so anything after would be much appreciated sir!

EDIT: EmuBro

  • I’ve tried following the instructions on King’s post… It did not work for me. All other solutions suggest its a bad image. Do you have another version of disc 2 you can upload?

EDIT 2:

  • I found a FAQ involving my issue and poster Arpanet lists off some additional Q&A for common issues. His #1
  • Q: My game freezes going into Cleyra!
    A: This is caused by using savestates. Save your game with a moogle, exit, and load the game via the “continue” option at the main menu.

My issue with this is that I’m unable to “exit”. I’ve attempted a soft restart by holding down buttons that take you back to the title screen- This did not work for me. Others have stated using a “permanent save” or a memory card. I’m not sure how to use a virtual memory card or anything other than a save state, so this doesn’t mean much to me, but maybe someone on here understands it.

Possibly something helpful to supply our save repository -

ff9 saves

  • These are in .mcr format- which I believe to memory card files. I’m uncertain if these can be converted or maybe reformatted to a .ggz save, but this is something that exists… and for possibly other games as well.
1 Like

HO.LEE.SHIT :angel: :poop:

I had no idea .ggz was just a gunzip archive type!

tar zxfv game-save-file.ggz and it opens up with a screenshot and a .psx file! I’m assuming if a .psx game save is from the same copy of a game, I should be able to just ggz it up and voila! :crossed_fingers:

I know what I’m trying out as soon as I’m done work!
If this works, you are a God amongst men sir @rook :bowing_man:

Well… I’ll be honest, I’m a king of troubleshooting- rather… information gathering. You name it, I’ll discover it or something similar. Like the above situation, I realize there are many different types of emulators (although I just discovered that memory card saves were a thing). I saw further that you could drag a save into a memory card folder (via ePSXe and it’ll convert to any psx emulator. My thoughts were that this was exclusive to windows emulators.

I’m coming to understand there is a large degree of information revolving around emulators- all of them being different and complex ofc.

I have no clue on the details, but you’ve managed to gain something from something I found… so power to you! lol. I’m just the cog- you be the machine!

Yeah I’m having the same problem with FF9, I get a black screen when the game is supposed to show Bahamut attacking Alexandria.

5 posts were merged into an existing topic: [SOLVED] Choppy Game Play with Normal FPS

4 posts were merged into an existing topic: FF9 freezing at Bahamut attacks Alexandria (disk 3)

Let’s try making our way through v1.1 to see if that does the trick.

https://emubrowser.com/games/psx/final-fantasy-ix-v11

I added v1.1 to see if things work out. Shitty thing is we’ll have to start from scratch - https://emubrowser.com/games/psx/final-fantasy-ix-v11