Chrono Cross CD2

I dont know if my save file was erased or if it just wont load.
And i cant upload my save file

1 Like

Let me take a look. I may have swapped it for some reason for another version.

I reverted to the previous version -

Let me know if your save file from disc 2 is working when you get the chance. If not, please upload it so I can troubleshoot the problem

I cant upload files.
To my memory i tried to use my save file on disc 2 and wasnt able to acces it through the save menager, cuz it was a file from the boat, not when the emulator asks to save. So i changed back to disc 1 and my file was no longer in the save manager.

I see… Do you still have your disc 2 save file? Upload it here if you can so I can possibly see what’s going on.

Cheers! :beers::video_game::canada:

Sorry, i had to replay the first cd, i think i overwrote the file. I still can’t load the file on cd 2, and dont know how to upload it here.
it says that i’m a new user

I’ve tried the save file from another player and still didn’t work either

Sorry about the wait. I swapped out disc 2 for another version that was working in the past and was able to load up disc2.

I believe I was trying other discs as there were reports that people were getting stuck in disc 2 at some point.

It worked on the other guy’s file, not mine.
I sent my file on discord, idk how to upload it here, ggz or ggs.
One is when it asks for the disc 2 and the other one when it asks to download your save file

1 Like

I replied to you on discord but here’s the ggz file from disc 2. Start by loading disc2 and upload the following to get started again:

chrono-cross.ggz (2.3 MB)

For future reference, you can just drag & drop files into the message window if you want to upload them here.