Ff9 disc 4 not loading

Trying to load ff9 disc 4 but it won’t even start loading. All other discs are functional. What should I do?

1 Like

Thanks for bringing this to our attention. Can you send me your most recent .ggz and .ggs saves for FF9? That’ll allow me to troubleshoot things easier from my end and hopefully apply a fix.

Actually, I don’t think I need you in order to look into this one. I’ll update this thread once I have a fix in place. Trying some things out now.

I had the incorrect file path for disc4 in place :man_facepalming: … Please try again and let us know if disc 4 is loading.

1 Like

final-fantasy-9-4.ggz (2.4 MB)

it keeps freezing when try to go into Lifa tree on disc 4. any ideas?

1 Like

Try the save and restart method described in this thread:

I tried your game save out, but couldn’t find an “in-game” save point in order to create the save data within the games memory.

After saving a game to the in-game memory card (not a .ggz created from the game player emulator), Reset the game by right-clicking the game window. Once reset, select Continue. Hopefully the save you made will be present and it will allow you to continue playing the game once it loads.

It worked. Thanks a lot!

1 Like