FF9 freezing at Bahamut attacks Alexandria (disk 3)

There is a scene on disk 3 of FF9 where Kuja attacks Alexandria with Bahamut. When it is time for the cinematic to load, it fades to black but no cinematic loads. Any advice on fixing this problem?

1 Like

Hey @DB11 Thanks for letting us know. I’d need a game save to start looking into it. You can upload one to the site if you’d like or share it by some other means (dropbox, google drive etc.).

I’ll poke around the internet to see if there’s anything floating around out there about it.

Thanks for your help! Uploaded the save to the save repository. Thanks for running the site, sure is nicer to use the computer with instant save states than to dust off all the original equipment and hope the CD’s still work.

1 Like

I have the same issue, waiting for you help, Thanks a lot

1 Like

Thanks for uploading that @DB11. I have your game save and will see if I can find a work around for this part.

I’ll let you know how it goes shortly as well @trix12345.

I uploaded a different version of disc. Big time problem though - your current disc 3 game saves won’t work. This is a warning to all of you currently enjoying FF9 - you won’t be able to get past this part with the current disc installed!!!

How for into disc 3 is this part at? Would you be alright with starting disc 3 over again to see if you’d be able to get past this part? If so, problem solved - just need to put a bit of work in. I can help if someone sends me a game save right at the end of disc 2.

Definitely not the best solution but if it works, we’re in the clear.

I had the chance to try it out last night from the start of the disk, it seems to work great now. Thank you very much for the help!

1 Like

Really? Just to confirm, were able to get past the part you were stuck at? If so, thank you so much for letting us know and for testing things out!


Yes, the cinematic now loads just fine and the game can progress past that point! Hooray!

1 Like

Sweet! :grin: :smile: :smiley: :grinning: :sweat_smile: :laughing: :rofl: :grin: :smile: :star_struck: :blush: :crazy_face: :smiley: :smile:

Users on the other thread are listing the same issue - I’d move them to this one as the issues are the same. Strangely, I wonder why this worked 12D ago, but is glitching for others now. Side note: Since he made it past the bahamut part, have him load that save state so others can skip it if they’re getting stuck.

Lastly - Could you try changing out disc 2 for FF9 so I can try to make it past my Cleyra freeze?

from everything I read… this is a save state issue. I have no clue how to work around it. The only thing I could think of would be to get someone else’s save state or play the game from scratch without exiting or use save states. Even on this … cross your fingers.

Do you have a save state for disc 2 - I’m stuck on entering Cleyra, I’d like to see if I can make it farther and possibly do it w/out closing my browser.

Bahamut cutscene and the tree are very popular freezing points. I believe Amarant scene froze on the actual discs when it came out

I had experienced the slow/skipping/choppy-like play before. Having a desktop that I built to hack a satellite or something, I can say that the issue isn’t on client-side. Some games play better on different browsers- you said you play on Chrome, which is the correct way to go for everything apart from N64 games. So let’s get to an answer if we can with some steps and logic- (if any of this brings an idea to you, maybe it’ll work out into a fix)

1st - I can play it smoothly: the issue is specific to you, which is the good news as we can narrow it down and be more likely to find a solution.
2nd - Assuming its specific to you, and you were able to play it 4 months ago… What has changed since then?
3rd - Check your update history. Drivers, Chrome, Plug-ins, Add-ons.
4th - Have you installed any new software, firewall, browser gizmos, etc?
5th - Attempt rollbacks on drivers, reinstall Chrome, reinstall an older version of Chrome.
6th - Try to use the site on different browsers. Waterfox (this one bugged on me), IE, Opera, others.

Last: do you have any FF9 save states from disc 2 after Cleyra? That’s where I’m stuck due to a glitch =/

1 Like

I do have a disk 2 save right at the end or before the final scene at the tree, but how do i share it on here?

1 Like

So the issue was a save file issue, by going back to disc 2 creating a new file going into disc 3 and then playing up till the bahamut attacks alexandria scene it managed to work.

Thanks! Another user was able to upload it right into a reply so that would work. The website also has the option of sharing it with other members here.

Thanks again for helping out!

3 posts were split to a new topic: [SOLVED] Choppy Game Play with High Frame Rate

Well it appears I was correct in the freeze issue being a save state-related problem. This apparently happens at least 3 times. Bahamut and Iifa tree are the most common scenes. thanks for the feedback @Kyurem77 !

@Kyurem77 - will you upload your save state AFTER the bahamut scene as well? It would help to be able to skip it when I get to that part

yeah I did, i didn’t name my saves after i downloaded them, but i believe the one i uploaded for disc 2 is around lifa tree and the one I uploaded for disc 3 is around lindblum, let me know if I uploaded the wrong save or if you want a different save.

i’m stuck right where you enter cleyra. The first screen you walk in, then the next area is the little scene where it shows the big tree… ya, i don’t get to see the big tree =/

I uploaded a save way past cleyra, but i can try and find a save past that, but i don’t have my saves labelled so it may be hard to find. Do you have a save on disk 1 cause cleyra is at the beginning of disk 2. You can try to go back to a burmecia save at the end of disk 1 and then create a new save going into disk 2, it worked with the bahamut scene for me.