[SOLVED] Choppy Game Play with Normal FPS

No, I have no save state anymore as even attempting to launch is slow and glitchy…actually just finished disc 1 on another site no problem, have that save state but probably couldn’t port it, and they do not have disc2 it seems.
Is the setup version of PAL rather than AUTO a thing, could something so simple be causing slow play and glitch? I noticed other sites had it setup that way…but if no one else is having this issue even starting up I may just be screwed.

1 Like

Hi @Hong_Kong_Phooey

I don’t think switching regions wouldn’t make a difference with regards to performance.

Do you have other things running in the background while playing a game? When you look at Activity Monitor, is there anything taking up a lot of CPU resources? I found from time-to-time on my Mac, a process called bsdtar would hog everything I had and would appear and disappear without warning

Here’s a quick video showing how FF9 performs on my machine to demonstrate it’s not necessarily the site causing the problem:

your hyperlink is spelled incorrectly - the “.com” part to be specific

1 Like

Hi all, I see there is a lot of discussion on the FF series and some issues that have come up so I’m just gonna leave this out there as it’s annoying as shit.
When this site initially ran I was able to run FF9 well, no issues other than helping to work out save states and disc changes 4 months ago…since, I am not able to run it at all as the speed, graphics and ‘glitch’ prevent gameplay as it’s so slow.
As I am able to run it ok on another site, which does not have 4 discs, I have been attempting to play disc1 off and on for 4 months now without success…does anyone have any suggestion that would help me reagin some sanity as to why this would be?!
Always run on Chrome with a MacBookAir with plenty of RAM and a good processor, so I am out of ideas as is our EmuBro…any and all help greatly appreciated.
Stay safe, sane and healthy everyone!

1 Like

Can you give it another shot? I removed the video ad and load times improved drastically. Not sure if this will translate to performance once the game has loaded, but it’s worth a try. Let me know if game play has improved at all :crossed_fingers:

[SOLVED] Clearing your browser cache seems to have resolve the issue. On Windows, hit CTRL+F5 and on a Mac, it’s Command+R.

CTRL+SHIFT+DEL will allow you to clear your browser cache as well

Please note that if you are currently in a game, the browser will refresh and you’ll have to download and start again. Please save your game before refreshing or you will lose your progress.

So…can I just say, thank you for all your time and patience with this noob, greatly appreciated!

1 Like

First time I ran into this, so thanks for your help figuring it out! Now hopefully I’ll be able to identify the problem right away and helps other who are having the same problem.


Thanks for the heads up!

1 Like