[SOLVED] FF7 freezing-Barret freeing Tifa from gas chamber (disk 2)

The game freezes in disk 2 in the scene where Heidegger sends soldiers to defend against the Weapon. It is when Barret meets Cait Sith and tries to free Tifa from the gas chamber. I have reloaded the game a few times, but it always freezes at the exact same moment. Any advise on this?

Chrome version: 80.0.3987.132 (official build) (64-bit)

1 Like

Thanks for letting us know. Can you share your most recent game save so I can troubleshoot the problem?


@EmuBro Of course. However, I am new here, so could you tell me how to do that?

You should be able to drag the file into the reply area. You can add it to the website as well by going here - https://emubrowser.com/save-file-repo

Let me know if you need anything else!

@EmuBro Ok, I added the save file there.
I tried, but could not drag it in the reply area here. I had this message:
“Sorry, the file you are trying to upload is not authorized (authorized extensions: jpg, jpeg, png, gif).”

In the file, without moving Barret, you have to press the circle button (or c key) 3 times and the scene with Heidegger will immediately begin.

Thanks for the help :slight_smile:

1 Like

Thanks @RinnaBird, see it on the site. I’ve also allowed .ggz file types to be uploaded.

Are you saying this is the solution? Press circle three times and you’re able to move on? Either way I’ll take a look - Thanks!

@EmuBro Ah, no, I guess I was not clear. It is not the solution, it is so the scene with the “freezing” will begin. I thought to add it because, personally, I would be confused to start a game at a completely random scene. The game will freeze a bit after Heidegger sends the soldiers away.

1 Like

Gotcha. Thanks for clearing things up! I’ll be in touch :crossed_fingers:

1 Like

Also getting stuck at the same part. How to continue? Keeps freezing at the exact same cutscene when Barret is freeing Tifa from gas chamber.


1 Like

Thanks. Looking into things now. Currently there is no fix.

Well, then I believe I have to stop playing the game for a while now. Thank you for your attention.

Umm is there a fix at the moment?

1 Like

wow 3.5 years later and i’m running into this same freeze in the same place

anything that can be done besides abandoning the game ?

1 Like

wow indeed
In my case, I ended up abandoning the game

I know right! Wait a second…

I’d love nothing more than to have FF7 not bug out as you mention, but I still require a save file to work things out on my end. I honestly can’t fit in the time to play FF7 up to this point in order troubleshoot. I’ll need is .ggz save file from a time before the freeze occurs to look into it and hopefully apply a fix. I was able to get things working for The Legend of Dragoon so I’m sure I can help out with FF7 as well.

You should be able to upload the save files to this thread. Drag and drop the file into the Reply area and I should be able to take a look.

I had added my old file in the old link “https://emubrowser.com/save-file-repo”, though it no longer works. Is there an archive of sorts where the file could still exist or is it permanently gone?
If you can fix, it I would love to continue playing but I unfortunately lost my files after all this time

hey really appreciate the attention to this, suspect it’s prob annoying people complaining about the free utility provided so big up for the option to play online existing in the first place.

unfortunately i can’t upload files because my forum account is too new ( created it just to post on this topic ) but here’s a wetransfer link to download a .ggz file saved just before the freeze

there’s a short dialogue sequence and you gotta try to open the door at the bottom of the screen to trigger the cinematic sequence where the glitch occurs


The site went through a big outage and I rebuilt it again. I decided to drop a few seldomly used features such as the save game repo in order to get back up and running as quickly as possible. Let me see if I still have those game saves backed up somewhere…

1 Like

Got the game save! Thanks!

I’ll try a few things out and will hopefully be in touch sometime within the next 3.5 years :wink: All jokes aside, I’ll try to get an answer for you sometime this weekend.

I’ll also look into new members not being able to upload files directly as I’m sure that will come up again.

I really appreciate you helping out with the process.

1 Like

I believe I was able to make progress with the fix we discovered from The Legend of Dragoon. Load your ggz game save and then create a new save within the game using the original FF7 save slot and not the ggz download save state. Once saved, right click the game window and select “Restart Game” It will boot back up and will contain your latest game save. Select “Continue” as it should detect and load your saved game from Slot 1. For some reason, all the other game saves were missing, but this method will allow you to pass the cut scene and continue playing.

Try it yourself when you get the chance. If you get stuck, here are some ggz files for before the FMV cut scene, and after:

final-fantasy-7-2-after-caith-sith.ggz (1.9 MB)
final-fantasy-7-2-post-cutscene.ggz (1.8 MB)

Let us know how things go!