[SOLVED] Legend of Dragoon Disc 3 Stalled

I am on disc 3 of Legend of Dragoon after fighting the divine dragon. I go back to Dennigrad and into the Crystal Palace to check on Shana and the queen. However, once I get to the throne room, the game stays on a black screen. I can still hear the background music, but the screen will not load. I have tried restarting the emulator, reloaded the browser, used different computers, etc. None seem to fix the issue.

Here is my save file: Dropbox - Legend of Dragoon, The (USA) (Disc 3) (15).ggz - Simplify your life

Can you try these instruction first? The key is to save the game to the built in memory card, then restart the game and then load from memory, not .ggz

If you are still getting that black screen, please let me know and I’ll see if I can get past it using your .ggz file

The reset method worked for me. Here’s an updated ggz for you:
Legend of Dragoon, The (USA) (Disc 3) (16).ggz (2.1 MB)

Oh ok - most of the black screen threads I saw were related to when people were changing discs so it didnt pretain to me. Sorry i missed this alternate saving method. Really appreciate the quick reply and the new save file. So helpful!

1 Like

No worries! This little trick seems to work more often than not. Thanks for visiting and let us know if anything else pops up.

I’ve uploaded disk two and uploaded my saved file, and after I right click to reset the game it will not allow me to do anything else. I need help!

Your details are sparse, so I’ll assume you’re missing some steps. When you’ve loaded your old game save and you’re on Disc 2, you’ll need to save your game to the memory card (think of how you’d save the game using save points etc) and not by downloading or using a copy of the .ggz/.ggs save state file.

After you have saved your game to the in-game memory card, right-click the game screen area and select Restart. When the game loads back up again, select “continue” and your memory card game save should be there. Select it, and the black screen issues should no longer be a problem.

That the problem. I was pass the saved mark in the second disk. I saved the game when it asked me to changed the disk. I’ve done through those steps just I did for the second disk, but it would not move forward. I’m trying again: loading the second disk, uploading the my last saved file, then I’m loading the third disk to began the third part. I don’t know where I’m messing up.

I’ll need your most recent game save file in order to test things out. You should be able to upload it here for me to take a look on my end. I’m looking for the file that ends in .ggz

Legend of Dragoon, The (USA) (Disc 2).ggz (2.2 MB)

Thank you for your help!

yeah, I don’t know what’s going on here but there’s definitely a problem. Do you have an older .ggz file for disc 2? I can’t think of why it’s freezing on the “Please Wait” when switching to disk 3. I’ll continue to try different things, but suspect a corrupt game save file or something along those lines is causing the problem.

As a temporary fix, I have another members disc 3 game save that works. Your stats and level will likely be different, but at least you’ll be able to play disc 3 :+1:

However, I have no idea how for this member was into disc 3 so you’ll probably miss a bit of story… :-1:

Switch to disc3 after the player has loaded the game (don’t worry about a save state etc) then upload the following game save to continue on:

Legend of Dragoon, The (USA) (Disc 3) (15).ggz (2.2 MB)

Legend of Dragoon, The (USA) (Disc 2) (1).ggz 20-47-18-040.ggz (2.0 MB)

You can try this one, but I don’t remember where I was with this saved file.