Final Fantasy VIII Disc 3 won't load

I haven’t been able to get FF VIII Disc 3 to load. I’ve made multiple attempts. Any ideas or workarounds I can try? Thanks!

I’ve also been having a similar problem with Chrono Cross Disc 2.

Can you send me your save file? I have reports of people loading disc 3 - but unfortunately end up being stuck in another spot - Final Fantasy 8 Freeze at Lunar Base

Your game save should be right before you’re prompted to switch discs. Thanks!
:canada::beers::video_game:

I’m new to this. How can I get it to you? Thanks for the help!

Never mind. I just discovered the repository. I uploaded both my last FF VIII save and my last CC save. Thanks!

1 Like

Thanks! I’ll take a look soon. Working on some exciting stuff right now so I might take a little longer than usual. Cheers!
:canada::beers::video_game: :

Any updates on this? Thanks for the help?

1 Like

sorry @elguapo1974 - gonna check it out now.

Looks like it worked for me. I created a ggz save as soon as disc 3 loaded. Try starting on disc 3 and use this save to continue on - Final Fantasy VIII (USA) (Disc 3).ggz (2.0 MB)

Let me know if everything working fine on your end.

Well… the emulator stops responding right after the lunar cry cut scene. The game seems to be moving, but I can’t get Squall to move and none of the controls work. I’ve backed the game up to the moments before, but it still stalls out at that point. I’ve reloaded multiple times. Same result.

No way around that I’m afraid. You can follow these threads but I’m pretty sure the problem is with the emulator or the game - both of which I’m unable to manipulate in order to troubleshoot anything.


https://forum.emubrowser.com/t/performance-issues/24/2

Was there anything you could do with the Chrono Cross file?

You can create a new topic under Support if you’d like to report a problem with Chrono Cross.

Good way to keep things all in one place. Thanks.